1SUMMARY = "A fast lightweight Text-to-speech engine"
2DESCRIPTION = "Mimic is a fast, lightweight Text-to-speech engine developed by Mycroft A.I. and VocaliD, based on Carnegie Mellon University’s Flite (Festival-Lite) software. Mimic takes in text and reads it out loud to create a high quality voice."
3HOMEPAGE = "https://mimic.mycroft.ai/"
4SECTION = "multimedia"
5
6# "Mimic is available under permissive BSD-like licenses"
7LICENSE = "MIT-X & \
8           PD & \
9           CMU-Tex & \
10           BSD & \
11           BSD-2-Clause & \
12           BSD-3-Clause & \
13           flite & \
14           (flite & Sun) & \
15           BellBird & \
16           Apache-2.0 \
17           "
18LIC_FILES_CHKSUM = "file://COPYING;md5=a2c2c7371b58b9cdeae0dc68846fe9f1"
19
20DEPENDS = "curl-native libpcre2"
21
22SRCREV = "adf655da0399530ac1b586590257847eb61be232"
23SRC_URI = "git://github.com/MycroftAI/mimic1.git \
24           file://0001-Fix-musl-compatibility.patch \
25           file://0001-cmu_indic_lang-Make-cst_rx_not_indic-as-extern-decla.patch \
26          "
27
28inherit autotools
29
30S = "${WORKDIR}/git"
31
32CPPFLAGS_append = " -Wno-error"
33