1SUMMARY = "C and C++ cross-platform library for decoding tracked music files (modules)"
2DESCRIPTION = "libopenmpt is a cross-platform C++ and C library to decode tracked \
3music files (modules) into a raw PCM audio stream. It also comes with openmpt123, a \
4cross-platform command-line or terminal based module file player. libopenmpt is based \
5on the player code of the OpenMPT project."
6HOMEPAGE = "https://lib.openmpt.org/libopenmpt/"
7SECTION = "libs"
8
9LICENSE = "BSD-3-Clause"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=59f6e21f42e49919617267ff13a0b232"
11
12DEPENDS = "virtual/libiconv"
13
14SRC_URI = "https://lib.openmpt.org/files/libopenmpt/src/libopenmpt-${PV}+release.autotools.tar.gz \
15           file://run-ptest \
16          "
17
18SRC_URI[sha256sum] = "2cf8369b7916b09264f3f14b9fb6cef35a6e9bee0328dec4f49d98211ccfd722"
19
20S = "${WORKDIR}/libopenmpt-${PV}+release.autotools"
21
22inherit autotools pkgconfig ptest
23
24PACKAGECONFIG ??= " \
25    openmpt123 \
26    ${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)} \
27    flac mpg123 ogg sndfile vorbis vorbisfile zlib \
28    ${@bb.utils.filter('DISTRO_FEATURES', 'pulseaudio', d)} \
29"
30
31PACKAGECONFIG[openmpt123]         = "--enable-openmpt123,--disable-openmpt123"
32PACKAGECONFIG[tests]              = "--enable-tests,--disable-tests"
33
34# These packageconfigs affect openmpt123
35PACKAGECONFIG[flac]               = "--with-flac,--without-flac,flac"
36PACKAGECONFIG[mpg123]             = "--with-mpg123,--without-mpg123,mpg123"
37PACKAGECONFIG[ogg]                = "--with-ogg,--without-ogg,libogg"
38PACKAGECONFIG[portaudio]          = "--with-portaudio,--without-portaudio,portaudio-v19"
39PACKAGECONFIG[pulseaudio]         = "--with-pulseaudio,--without-pulseaudio,pulseaudio"
40PACKAGECONFIG[sdl2]               = "--with-sdl2,--without-sdl2,libsdl2"
41PACKAGECONFIG[sndfile]            = "--with-sndfile,--without-sndfile,libsndfile1"
42PACKAGECONFIG[vorbis]             = "--with-vorbis,--without-vorbis,libvorbis"
43PACKAGECONFIG[vorbisfile]         = "--with-vorbisfile,--without-vorbisfile,libvorbis"
44PACKAGECONFIG[zlib]               = "--with-zlib,--without-zlib,zlib"
45
46EXTRA_OECONF += " \
47    --disable-doxygen-doc \
48    --disable-examples \
49    --without-portaudiocpp \
50"
51
52do_compile_ptest() {
53    oe_runmake ${PARALLEL_MAKE} libopenmpttest
54}
55
56do_install_ptest() {
57    install -d ${D}${PTEST_PATH}/test
58    install -m 0755 ${B}/libopenmpttest ${D}${PTEST_PATH}
59    install -m 0644 ${S}/test/test.mptm ${D}${PTEST_PATH}/test
60    install -m 0644 ${S}/test/test.s3m ${D}${PTEST_PATH}/test
61    install -m 0644 ${S}/test/test.xm ${D}${PTEST_PATH}/test
62
63    install -d ${D}${PTEST_PATH}/libopenmpt
64    install -m 0644 ${S}/libopenmpt/libopenmpt_version.mk ${D}${PTEST_PATH}/libopenmpt
65}
66
67PACKAGES =+ "${PN}-openmpt123 ${PN}-openmpt123-doc"
68FILES:${PN}-openmpt123 = "${bindir}/openmpt123"
69FILES:${PN}-openmpt123-doc = "${mandir}/man1/openmpt123*"
70
71# Since version 0.3, libopenmpt uses SemVer 2.0.0 versioning.
72# The SemVer versioning scheme is incompatible with Debian/Ubuntu
73# package version names.
74DEBIAN_NOAUTONAME:${PN} = "1"
75
76RDEPENDS:${PN}:libc-glibc = " \
77    glibc-gconv \
78    glibc-gconv-cp1252 \
79    glibc-gconv-ibm437 \
80    glibc-gconv-iso8859-1 \
81    glibc-gconv-iso8859-15 \
82"
83