1SUMMARY = "Gst-Shark Tracers"
2DESCRIPTION = "Benchmarks and profiling tools for GStreamer"
3HOMEPAGE = "https://developer.ridgerun.com/wiki/index.php?title=GstShark"
4SECTION = "multimedia"
5
6LICENSE = "GPL-2.0-or-later"
7LIC_FILES_CHKSUM = "file://COPYING;md5=e1caa368743492879002ad032445fa97"
8
9DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad "
10
11SRCBRANCH ?= "master"
12
13SRCREV = "09ba05865dacd2824b5b40ab75a4b9545fcc1366"
14SRCREV_common = "b64f03f6090245624608beb5d2fff335e23a01c0"
15SRCREV_FORMAT = "default_common"
16SRC_URI = " \
17    git://github.com/RidgeRun/gst-shark.git;protocol=https;branch=${SRCBRANCH} \
18    git://gitlab.freedesktop.org/gstreamer/common.git;protocol=https;branch=master;destsuffix=git/common;name=common \
19    file://0001-tracers-Fix-buffer-overflow.patch \
20"
21
22S = "${WORKDIR}/git"
23
24EXTRA_OECONF += " \
25    --disable-graphviz \
26    --enable-gtk-doc=no \
27"
28
29FILES:${PN} += "\
30    ${libdir}/gstreamer-1.0/libgstsharktracers.so  \
31    ${libdir}/gstreamer-1.0/libgstsharktracers.la \
32"
33
34inherit autotools gettext pkgconfig
35