1SUMMARY = "Flite: a small run-time speech synthesis engine"
2HOMEPAGE = "http://cmuflite.org"
3SECTION = "libs/multimedia"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b3b732d1349633a53e69356607fd2d6c"
6
7inherit autotools-brokensep
8
9DEPENDS += "alsa-lib chrpath-replacement-native"
10
11SRC_URI = "git://github.com/festvox/flite.git;protocol=https;branch=master"
12
13SRCREV = "e9e2e37c329dbe98bfeb27a1828ef9a71fa84f88"
14
15S = "${WORKDIR}/git"
16
17EXTRA_OECONF += "--enable-shared"
18
19do_configure:append() {
20    sed -i '/$(INSTALL) -m 755 $(BINDIR)\/flite_time $(DESTDIR)$(INSTALLBINDIR)/d' ${S}/main/Makefile
21}
22
23do_install:append() {
24    chown -R root:root ${D}${libdir}/*
25}
26# | make[1]: *** No rule to make target 'flite_voice_list.c', needed by 'all'.  Stop.
27PARALLEL_MAKE = ""
28