1SUMMARY = "DLNA server libraries"
2DESCRIPTION = "dleyna-server is a library for implementing services that \
3allow clients to discover, browse and manipulate Digital Media Servers. \
4An implementation of such a service for linux is also included."
5HOMEPAGE = "https://01.org/dleyna/"
6
7LICENSE = "LGPL-2.1-or-later"
8LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c \
9                    file://libdleyna/server/server.c;endline=22;md5=437455d8aeff69ebd0996a76c67397bb"
10
11DEPENDS = "glib-2.0 gssdp gupnp gupnp-av gupnp-dlna libsoup-2.4 libxml2 dleyna-core"
12RDEPENDS:${PN} = "dleyna-connector-dbus"
13
14PV .= "+git${SRCPV}"
15SRC_URI = "git://github.com/01org/${BPN}.git;branch=master;protocol=https"
16SRCREV = "eb895ae82715e9889a948ffa810c0f828b4f4c76"
17S = "${WORKDIR}/git"
18
19inherit autotools pkgconfig
20
21FILES:${PN} += "${datadir}/dbus-1"
22FILES:${PN}-dev += "${libdir}/${BPN}/*.so"
23