1SUMMARY = "Portable SDK for UPnP* Devices"
2DESCRIPTION = "The Portable SDK for UPnP Devices is an SDK for development of \
3UPnP device and control point applications. It consists of the core UPnP \
4protocols along with a UPnP-specific eXtensible Markup Language (XML) parser \
5supporting the Document Object Model (DOM) Level 2 API and an optional, \
6integrated mini web server for serving UPnP related documents."
7HOMEPAGE = "http://pupnp.sourceforge.net/"
8LICENSE = "BSD-3-Clause"
9LIC_FILES_CHKSUM = "file://COPYING;md5=394a0f17b97f33426275571e15920434"
10
11SRCREV = "c540ce2431bdeac73359029d4592b45790e1d154"
12SRC_URI = "git://github.com/pupnp/pupnp.git;protocol=https;branch=branch-1.14.x \
13          "
14
15S="${WORKDIR}/git"
16
17inherit autotools pkgconfig
18
19EXTRA_OECONF += "--enable-reuseaddr"
20
21# Enable LFS support ( for samples )
22CFLAGS += "-D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE"
23CXXFLAGS += "-D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE"
24