1###########################
2# Configure options:
3#
4#  --enable-static-linking compile kexecboot as static executable [default=no]
5#  --enable-fbui           support framebuffer menu [default=yes]
6#  --enable-fbui-width     limit FB UI width to specified value [default=no]
7#  --enable-fbui-height    limit FB UI height to specified value [default=no]
8#  --enable-textui         support console text user interface [default=no]
9#  --enable-cfgfiles       support config files [default=yes]
10#  --enable-icons          support custom icons (depends on fbui) [default=yes]
11#  --enable-zaurus         compile Sharp Zaurus specific code [default=no]
12#  --enable-zimage         compile with zImage support [default=yes]
13#  --enable-uimage         compile with uImage support [default=no]
14#  --enable-machine-kernel look for machine-specific zImage kernel [default=no]
15#  --enable-devices-recreating
16#                          enable devices re-creating [default=yes]
17#  --enable-debug          enable debug output [default=no]
18#  --enable-host-debug     allow for non-destructive executing of kexecboot on
19#                            host system [default=no]
20#  --enable-numkeys        enable menu item selection by keys [0-9] [default=yes]
21#  --enable-bg-buffer      enable buffer for pre-drawed FB GUI background
22#
23#  --enable-timeout        allow to boot 1st kernel after timeout in seconds
24#                            [default=no]
25#  --enable-delay          specify delay before device scanning, allowing
26#                            initialization of old CF/SD cards [default=1]
27#  --enable-bpp            enable support of specified bpp modes
28#                            (all,32,24,18,16,4,2,1) [default=all]
29#  --enable-evdev-rate     change evdev (keyboard/mouse) repeat rate
30#                            in milliseconds e.g. "1000,250" [default=no]
31#  --with-kexec-binary     look for kexec binary at path
32#                            [default="/usr/sbin/kexec"]
33##########################
34SUMMARY = "kexecboot linux-as-bootloader"
35DESCRIPTION = "kexecboot is a graphical linux-as-bootloader implementation based on kexec."
36HOMEPAGE = "http://kexecboot.org"
37LICENSE = "GPLv2"
38LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
39PV = "0.6+git${SRCPV}"
40S = "${WORKDIR}/git"
41SRC_URI = "git://github.com/kexecboot/kexecboot.git"
42SRCREV = "4c4f127e79ac5b8d6b6e2fbb938ccbf12b04c531"
43inherit autotools
44
45EXTRA_OECONF = "--enable-textui --enable-delay=2 --enable-evdev-rate=1000,250"
46
47do_install () {
48    install -d ${D}${bindir}
49    install -m 0755 kexecboot ${D}${bindir}
50    install -d ${D}/proc
51    install -d ${D}/mnt
52    install -d ${D}/dev
53    install -d ${D}/sys
54}
55
56PACKAGE_ARCH = "${MACHINE_ARCH}"
57
58FILES_${PN} += " ${bindir}/kexecboot /init /proc /mnt /dev /sys"
59
60pkg_postinst_${PN} () {
61    ln -sf ${bindir}/kexecboot $D/init
62}
63
64BBCLASSEXTEND = "klibc"
65