1SUMMARY = "kexecboot linux-as-bootloader"
2DESCRIPTION = "kexecboot is a graphical linux-as-bootloader implementation based on kexec."
3HOMEPAGE = "http://kexecboot.org"
4LICENSE = "GPL-2.0-only"
5LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
6PV = "0.6+git${SRCPV}"
7S = "${WORKDIR}/git"
8SRC_URI = "git://github.com/kexecboot/kexecboot.git;branch=master;protocol=https"
9SRC_URI:append:libc-klibc = "\
10    file://0001-kexecboot-Use-new-reboot-API-with-klibc.patch \
11    file://0001-make-Add-compiler-includes-in-cflags.patch \
12"
13SRCREV = "5a5e04be206140059f42ac786d424da1afaa04b6"
14inherit autotools
15
16EXTRA_OECONF = "--enable-textui --enable-delay=2 --enable-evdev-rate=1000,250"
17
18CFLAGS += "-fcommon"
19
20do_install () {
21    install -D -m 0755 ${B}/src/kexecboot ${D}${bindir}/kexecboot
22    install -d ${D}/proc
23    install -d ${D}/mnt
24    install -d ${D}/dev
25    install -d ${D}/sys
26}
27
28PACKAGE_ARCH = "${MACHINE_ARCH}"
29
30FILES:${PN} += " ${bindir}/kexecboot /init /proc /mnt /dev /sys"
31
32pkg_postinst:${PN} () {
33    ln -sf ${bindir}/kexecboot $D/init
34}
35
36BBCLASSEXTEND = "klibc"
37