1SUMMARY = "Configuration files for kexecboot"
2DESCRIPTION = "Default icon and boot.cfg for kexecboot linux-as-bootloader."
3SECTION = "base"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
6
7SRC_URI = "file://icon.xpm"
8
9S = "${WORKDIR}/sources"
10UNPACKDIR = "${S}"
11
12do_install:prepend () {
13echo '# /boot/boot.cfg - KEXECBOOT configuration file.
14#
15# First kernel stanza.
16# Show this label in kexecboot menu.
17#
18LABEL=${KEXECBOOT_LABEL}
19#
20# Specify full kernel path on target.
21KERNEL=/boot/${KERNEL_IMAGETYPE}
22#
23# Specify which device tree blob to use
24# DTB=/boot/my-own-dtb
25#
26# Append this tags to the kernel cmdline.
27APPEND=${CMDLINE} ${CMDLINE_DEBUG}
28#
29# Overwrite kernel command line instead of appending to it
30# CMDLINE=console=/dev/tty0 root=/dev/sdb1
31#
32# Specify optional initrd/initramfs.
33# INITRD=/boot/initramfs.cpio.gz
34#
35# Specify full path for a custom icon for the menu-item.
36# If not set, use device-icons as default (NAND, SD, CF, ...).
37# ICON=/boot/icon.xpm
38#
39# Priority of item in kexecboot menu.
40# Items with highest priority will be shown at top of menu.
41# Default: 0 (lowest, ordered by device ordering)
42# PRIORITY=10
43#
44#
45# Second kernel stanza.
46# LABEL=${KEXECBOOT_LABEL}-test
47# KERNEL=/boot/${KERNEL_IMAGETYPE}-test
48# APPEND=${CMDLINE}
49#' > ${S}/boot.cfg
50}
51do_install () {
52    install -d ${D}/boot
53    install -m 0644 boot.cfg ${D}/boot/boot.cfg
54    install -m 0644 icon.xpm ${D}/boot/icon.xpm
55}
56
57PACKAGE_ARCH = "${MACHINE_ARCH}"
58
59FILES:${PN} += "/boot/*"
60
61CMDLINE ?= ""
62CMDLINE_DEBUG ?= "quiet"
63
64INHIBIT_DEFAULT_DEPS = "1"
65
66# Note: for qvga the label is currently limited to about 24 chars
67KEXECBOOT_LABEL ?= "${@d.getVar('DISTRO') or d.getVar('DISTRO_VERSION')}-${MACHINE}"
68