xref: /openbmc/openbmc/meta-openembedded/meta-initramfs/recipes-bsp/kexecboot/kexecboot-cfg_0.2.bb (revision edff49234e31f23dc79f823473c9e286a21596c1)
1eb8dc403SDave CobbleySUMMARY = "Configuration files for kexecboot"
2eb8dc403SDave CobbleyDESCRIPTION = "Default icon and boot.cfg for kexecboot linux-as-bootloader."
3eb8dc403SDave CobbleySECTION = "base"
4eb8dc403SDave CobbleyLICENSE = "MIT"
5eb8dc403SDave CobbleyLIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
6eb8dc403SDave Cobbley
7eb8dc403SDave CobbleySRC_URI = "file://icon.xpm"
8eb8dc403SDave Cobbley
9*edff4923SAndrew GeisslerS = "${WORKDIR}/sources"
10*edff4923SAndrew GeisslerUNPACKDIR = "${S}"
11eb8dc403SDave Cobbley
12213cb269SPatrick Williamsdo_install:prepend () {
13eb8dc403SDave Cobbleyecho '# /boot/boot.cfg - KEXECBOOT configuration file.
14eb8dc403SDave Cobbley#
15eb8dc403SDave Cobbley# First kernel stanza.
16eb8dc403SDave Cobbley# Show this label in kexecboot menu.
17eb8dc403SDave Cobbley#
18eb8dc403SDave CobbleyLABEL=${KEXECBOOT_LABEL}
19eb8dc403SDave Cobbley#
20eb8dc403SDave Cobbley# Specify full kernel path on target.
21eb8dc403SDave CobbleyKERNEL=/boot/${KERNEL_IMAGETYPE}
22eb8dc403SDave Cobbley#
231a4b7ee2SBrad Bishop# Specify which device tree blob to use
241a4b7ee2SBrad Bishop# DTB=/boot/my-own-dtb
251a4b7ee2SBrad Bishop#
26eb8dc403SDave Cobbley# Append this tags to the kernel cmdline.
27eb8dc403SDave CobbleyAPPEND=${CMDLINE} ${CMDLINE_DEBUG}
28eb8dc403SDave Cobbley#
291a4b7ee2SBrad Bishop# Overwrite kernel command line instead of appending to it
301a4b7ee2SBrad Bishop# CMDLINE=console=/dev/tty0 root=/dev/sdb1
311a4b7ee2SBrad Bishop#
32eb8dc403SDave Cobbley# Specify optional initrd/initramfs.
33eb8dc403SDave Cobbley# INITRD=/boot/initramfs.cpio.gz
34eb8dc403SDave Cobbley#
35eb8dc403SDave Cobbley# Specify full path for a custom icon for the menu-item.
36eb8dc403SDave Cobbley# If not set, use device-icons as default (NAND, SD, CF, ...).
37eb8dc403SDave Cobbley# ICON=/boot/icon.xpm
38eb8dc403SDave Cobbley#
39eb8dc403SDave Cobbley# Priority of item in kexecboot menu.
40eb8dc403SDave Cobbley# Items with highest priority will be shown at top of menu.
41eb8dc403SDave Cobbley# Default: 0 (lowest, ordered by device ordering)
42eb8dc403SDave Cobbley# PRIORITY=10
43eb8dc403SDave Cobbley#
44eb8dc403SDave Cobbley#
45eb8dc403SDave Cobbley# Second kernel stanza.
46eb8dc403SDave Cobbley# LABEL=${KEXECBOOT_LABEL}-test
47eb8dc403SDave Cobbley# KERNEL=/boot/${KERNEL_IMAGETYPE}-test
48eb8dc403SDave Cobbley# APPEND=${CMDLINE}
49eb8dc403SDave Cobbley#' > ${S}/boot.cfg
50eb8dc403SDave Cobbley}
51eb8dc403SDave Cobbleydo_install () {
52eb8dc403SDave Cobbley    install -d ${D}/boot
53eb8dc403SDave Cobbley    install -m 0644 boot.cfg ${D}/boot/boot.cfg
54eb8dc403SDave Cobbley    install -m 0644 icon.xpm ${D}/boot/icon.xpm
55eb8dc403SDave Cobbley}
56eb8dc403SDave Cobbley
57eb8dc403SDave CobbleyPACKAGE_ARCH = "${MACHINE_ARCH}"
58eb8dc403SDave Cobbley
59213cb269SPatrick WilliamsFILES:${PN} += "/boot/*"
60eb8dc403SDave Cobbley
61eb8dc403SDave CobbleyCMDLINE ?= ""
62eb8dc403SDave CobbleyCMDLINE_DEBUG ?= "quiet"
63eb8dc403SDave Cobbley
64eb8dc403SDave CobbleyINHIBIT_DEFAULT_DEPS = "1"
65eb8dc403SDave Cobbley
66eb8dc403SDave Cobbley# Note: for qvga the label is currently limited to about 24 chars
67eb8dc403SDave CobbleyKEXECBOOT_LABEL ?= "${@d.getVar('DISTRO') or d.getVar('DISTRO_VERSION')}-${MACHINE}"
68