1SUMMARY = "A xdg-desktop-portal backend for gnome."
2HOMEPAGE = "https://gitlab.gnome.org/GNOME/xdg-desktop-portal-gnome"
3LICENSE = "LGPL-2.1-only"
4LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
5
6DEPENDS = " \
7    glib-2.0-native \
8    gtk4\
9    xdg-desktop-portal \
10    xdg-desktop-portal-gtk \
11    libadwaita \
12    fontconfig \
13    gsettings-desktop-schemas \
14    gnome-desktop \
15    dconf \
16"
17
18RDEPENDS:${PN} = "xdg-desktop-portal xdg-desktop-portal-gtk"
19
20inherit gnomebase pkgconfig gsettings features_check
21
22REQUIRED_DISTRO_FEATURES = "polkit"
23
24SRC_URI[archive.sha256sum] = "5d2d533597d280b7370b8f74faa40097b292b0036dbd59166e1312230500bb8b"
25
26PACKAGECONFIG ?= "screenshot screencast ${@bb.utils.filter('DISTRO_FEATURES', 'wayland', d)}"
27PACKAGECONFIG[wayland] = ",,wayland-native"
28PACKAGECONFIG[screenshot] = ",,,gnome-shell"
29PACKAGECONFIG[screencast] = ",,,mutter"
30
31FILES:${PN} += "${systemd_user_unitdir} ${datadir}"
32