1SUMMARY = "user and group account administration library"
2DESCRIPTION = "The libuser library implements a standardized interface for manipulating and administering user \
3and group accounts"
4HOMEPAGE = "https://pagure.io/libuser"
5BUGTRACKER = "https://pagure.io/libuser/issues"
6
7LICENSE = "LGPL-2.0-only"
8LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2 \
9                    file://lib/user.h;endline=19;md5=76b301f63c39fa992062395efbdc9558 \
10                    file://samples/testuser.c;endline=19;md5=3b87fa660fa3f4a6bb31d624afe30ba1"
11
12SECTION = "base"
13
14SRC_URI = "https://releases.pagure.org/libuser/libuser-${PV}.tar.gz \
15           file://0001-docs-Disable-building.patch \
16           file://0002-remove-unused-execinfo.h.patch \
17           "
18
19SRC_URI[sha256sum] = "ea6094c72cb9e60a42fb53509dc98d124a340f1c9222783b503208adc16a0a8f"
20
21DEPENDS = "bison-native popt libpam glib-2.0 python3"
22
23inherit autotools features_check gettext python3native python3-dir pkgconfig gtk-doc
24
25REQUIRED_DISTRO_FEATURES = "pam"
26
27EXTRA_OEMAKE = "PYTHON_CPPFLAGS=-I${STAGING_INCDIR}/${PYTHON_DIR}${PYTHON_ABI}"
28
29GTKDOC_DOCDIR = "${S}/docs/reference"
30
31# run autopoint since it needs ABOUT-NLS and admin/config.rpath from gettext
32#EXTRA_AUTORECONF:remove = "--exclude=autopoint"
33
34do_configure:prepend() {
35    install -d ${S}/admin -d ${S}/m4
36    touch ${S}/ABOUT-NLS ${S}/admin/config.rpath
37    cd ${S}
38    bison lib/getdate.y -o lib/getdate.c
39    cd -
40}
41
42PACKAGES += "${PN}-python "
43
44FILES:${PN}-python = "${PYTHON_SITEPACKAGES_DIR}"
45
46