1DESCRIPTION = "keybinder is a library for registering global key bindings, for gtk-based applications."
2HOMEPAGE = "https://github.com/engla/keybinder"
3LICENSE = "X11"
4SECTION = "devel/lib"
5DEPENDS = "gtk+3 gobject-introspection-native \
6           gtk+ \
7"
8
9LIC_FILES_CHKSUM = "file://COPYING;md5=1f18f9c6d8b4cfcc7d7804a243a4c0b4"
10
11S = "${WORKDIR}/git"
12
13SRCREV = "736ccef40d39603b8111c8a3a0bca0319bbafdc0"
14PV = "3.0+git"
15SRC_URI = "git://github.com/engla/keybinder.git;branch=keybinder-3.0;protocol=https \
16"
17
18RDEPENDS:${PN} = "gtk+"
19
20inherit features_check autotools-brokensep gtk-doc gobject-introspection
21
22REQUIRED_DISTRO_FEATURES = "x11"
23do_configure:prepend() {
24	touch ${S}/ChangeLog
25}
26
27# gtk-doc generation doesn't work, so disable it:
28# ../keybinder-docs.sgml:26: element include: XInclude error : could not load ../xml/tree_index.sgml, and no fallback was found
29GTKDOC_ENABLED = "False"
30