1SUMMARY = "GNOME tweaks: Advanced options for GNOME 3 session"
2LICENSE = "GPL-3.0-only & CC0-1.0"
3LIC_FILES_CHKSUM = " \
4    file://LICENSES/CC0-1.0;md5=65d3616852dbf7b1a6d4b53b00626032 \
5    file://LICENSES/GPL-3.0;md5=9eef91148a9b14ec7f9df333daebc746 \
6"
7
8DEPENDS = "libhandy"
9
10GNOMEBASEBUILDCLASS = "meson"
11
12inherit gnomebase gtk-icon-cache gobject-introspection features_check
13
14# same as gnome-shell
15REQUIRED_DISTRO_FEATURES = "x11 polkit systemd pam"
16
17# gobject-introspection is mandatory and cannot be configured
18REQUIRED_DISTRO_FEATURES += "gobject-introspection-data"
19GIR_MESON_OPTION = ""
20
21SRC_URI[archive.sha256sum] = "f95f3fe031b0b01c02f79a1659f889152d3772ae3e44df8403d1460ba5eec36a"
22SRC_URI += " \
23    file://0001-Make-python-path-configurable.patch \
24    file://0002-meson-fix-invalid-positional-argument.patch \
25"
26
27EXTRA_OEMESON = "-Dpython_site_dir=${PYTHON_SITEPACKAGES_DIR}"
28
29FILES:${PN} += " \
30    ${datadir}/metainfo \
31    ${PYTHON_SITEPACKAGES_DIR} \
32"
33
34RDEPENDS:${PN} += "gnome-shell python3-core python3-logging libhandy"
35