1SUMMARY = "Access, organize and share your photos on GNOME"
2SECTION = "x11/gnome"
3LICENSE = "GPL-3.0-only"
4LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464"
5
6DEPENDS = " \
7    cairo \
8    glib-2.0-native \
9    gdk-pixbuf-native \
10    librsvg-native \
11    gtk+3 \
12    babl \
13    dbus \
14    gegl \
15    geocode-glib \
16    gexiv2 \
17    gnome-online-accounts \
18    gsettings-desktop-schemas \
19    libdazzle \
20    tracker \
21    libhandy \
22    libportal \
23"
24
25RDEPENDS:${PN} = "tracker-miners"
26
27
28inherit gnomebase gettext gnome-help features_check
29
30def gnome_verdir(v):
31    return oe.utils.trim_version(v, 1)
32
33REQUIRED_DISTRO_FEATURES = "x11 opengl gobject-introspection-data"
34
35PACKAGECONFIG ?= ""
36PACKAGECONFIG[doc] = "-Dmanuals=true,-Dmanuals=false,libxslt-native docbook-xsl-stylesheets-native"
37
38SRC_URI[archive.sha256sum] = "e78e210397d3c62809c6cd5521da6eccb4a11ddea5bf2af8632a47f4da5c829e"
39
40do_install:append() {
41    # make gnome-photos available on all desktops
42    sed -i 's:OnlyShowIn=:#OnlyShowIn=:g' ${D}${datadir}/applications/org.gnome.Photos.desktop
43}
44
45FILES:${PN} += " \
46    ${datadir}/dbus-1 \
47    ${datadir}/metainfo \
48    ${datadir}/gnome-shell \
49"
50
51do_compile:append() {
52    # glib-mkenums is embedding full paths into this file. There's no
53    # option to it to use a sysroot style variable. So to avoid QA
54    # errors, we sed WORKDIR out and make its includes relative
55    sed -i "s|${B}||" src/photos-enums.h
56    sed -i "s|${B}||" src/photos-enums.c
57    sed -i "s|${B}||" src/photos-enums-gegl.c
58    sed -i "s|${B}||" src/photos-enums-gegl.h
59}
60