1SUMMARY = "GNOME Settings"
2DESCRIPTION = "GNOME Settings is GNOME's main interface for configuration of various aspects of your desktop"
3LICENSE = "GPL-2.0-only"
4LIC_FILES_CHKSUM = "file://COPYING;md5=75859989545e37968a99b631ef42722e"
5
6GTKIC_VERSION = "4"
7
8DEPENDS = " \
9    accountsservice \
10    colord-gtk \
11    gcr \
12    gdk-pixbuf \
13    glib-2.0 \
14    gnome-bluetooth \
15    gnome-desktop \
16    gnome-online-accounts \
17    gnome-settings-daemon \
18    gsettings-desktop-schemas \
19    gtk4 \
20    libadwaita \
21    libepoxy \
22    libgtop \
23    libgudev \
24    libnma \
25    libpwquality \
26    libxml2 \
27    polkit \
28    pulseaudio \
29    samba \
30    setxkbmap-native \
31    tecla \
32    udisks2 \
33    upower \
34"
35
36inherit gtk-icon-cache pkgconfig gnomebase gsettings gettext upstream-version-is-even bash-completion features_check useradd
37
38REQUIRED_DISTRO_FEATURES += "opengl polkit pulseaudio systemd x11"
39
40SRC_URI += "file://0001-Add-meson-option-to-pass-sysroot.patch"
41SRC_URI[archive.sha256sum] = "6335c6cb8164e574db521fff61cfa3dfaa55f1db66ae3bca02750a193e1c4f3d"
42
43PACKAGECONFIG ??= "ibus ${@bb.utils.filter('DISTRO_FEATURES', 'wayland', d)}"
44PACKAGECONFIG[cups] = ",,cups,cups system-config-printer cups-pk-helper"
45PACKAGECONFIG[ibus] = "-Dibus=true, -Dibus=false, ibus"
46PACKAGECONFIG[wayland] = "-Dwayland=true, -Dwayland=false, wayland"
47PACKAGECONFIG[file-share] = ",,,gnome-user-share"
48PACKAGECONFIG[media-share] = ",,,rygel-meta tumbler"
49PACKAGECONFIG[malcontent] = "-Dmalcontent=true,-Dmalcontent=false,malcontent,malcontent-ui"
50
51EXTRA_OEMESON += "-Doe_sysroot=${STAGING_DIR_HOST}"
52
53export XDG_DATA_DIRS = "${STAGING_DATADIR}"
54
55USERADD_PACKAGES = "${PN}"
56USERADD_PARAM:${PN} = "--system --no-create-home --user-group --home-dir ${sysconfdir}/polkit-1 polkitd"
57
58do_install:append() {
59    if [ -d ${D}${datadir}/polkit-1/rules.d ]; then
60        chmod 700 ${D}${datadir}/polkit-1/rules.d
61        chown polkitd:root ${D}${datadir}/polkit-1/rules.d
62    fi
63}
64
65PACKAGE_DEBUG_SPLIT_STYLE = "debug-without-src"
66
67FILES:${PN} += " \
68    ${datadir}/dbus-1 \
69    ${datadir}/gnome-shell \
70    ${datadir}/metainfo \
71"
72
73FILES:${PN}-dev += "${datadir}/gettext"
74
75RDEPENDS:${PN} += "gsettings-desktop-schemas tecla"
76