1SUMMARY = "GNOME bluetooth manager"
2LICENSE = "GPL-2.0-only & LGPL-2.1-only"
3LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a \
4                    file://COPYING.LIB;md5=a6f89e2100d9b6cdffcea4f398e37343 \
5"
6
7SECTION = "x11/gnome"
8
9DEPENDS = "udev gtk+3 libnotify libcanberra bluez5"
10
11GNOMEBN = "gnome-bluetooth"
12S = "${WORKDIR}/${GNOMEBN}-${PV}"
13
14GNOMEBASEBUILDCLASS = "meson"
15GTKDOC_MESON_OPTION = "gtk_doc"
16
17inherit features_check gnomebase gtk-icon-cache gtk-doc gobject-introspection upstream-version-is-even
18
19REQUIRED_DISTRO_FEATURES = "x11"
20
21# gtk-icon-cache bbclass will take care of this for us.
22EXTRA_OEMESON = "-Dicon_update=false"
23
24SRC_URI += " file://0001-build-Fix-build-for-newer-versions-of-meson.patch"
25SRC_URI[archive.md5sum] = "d83faa54abaf64bb40b5313bc233e74e"
26SRC_URI[archive.sha256sum] = "6c949e52c8becc2054daacd604901f66ce5cf709a5fa91c4bb7cacc939b53ea9"
27
28# avoid clashes with gnome-bluetooth
29do_install:append() {
30    # just bluetooth-sendto / bluetooth-sendto.desktop only
31    rm -rf ${D}${bindir}
32    rm -rf ${D}${datadir}/applications
33}
34
35FILES:${PN} += "${datadir}/gnome-bluetooth"
36
37# offer alternate bluetooth-sendto
38RRECOMMENS:${PN} += "gnome-bluetooth"
39
40RDEPENDS:${PN} += "bluez5"
41