1SUMMARY = "A GObject library for Facebook Graph API"
2SECTION = "x11/gnome"
3LICENSE = "LGPL-2.1-only"
4LIC_FILES_CHKSUM = "file://COPYING;md5=5804fe91d3294da4ac47c02b454bbc8a"
5
6DEPENDS = " \
7    glib-2.0 \
8    json-glib \
9    rest \
10    gnome-online-accounts \
11"
12
13inherit gnomebase gtk-doc gobject-introspection pkgconfig features_check
14
15# for gnome-online-accounts
16REQUIRED_DISTRO_FEATURES = "x11"
17
18SRC_URI += " file://0001-Update-rest-requirement-to-rest-1.0.patch"
19SRC_URI[archive.sha256sum] = "9cb381b3f78ba1136df97af3f06e3b11dcc2ab339ac08f74eda0f8057d6603e3"
20
21do_install:append() {
22    # they install all the autotools files (NEWS AUTHORS..) to /usr/doc which
23    # is not a standard path exactly
24    rm -rf ${D}${prefix}/doc
25}
26