1SUMMARY = "This is the Eye of GNOME, an image viewer program."
2LICENSE = "GPL-2.0-only"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
4
5DEPENDS = " \
6    librsvg \
7    gnome-desktop \
8    gsettings-desktop-schemas \
9    gdk-pixbuf \
10    gtk+3 \
11    libhandy \
12    libpeas \
13    libportal \
14    libexif \
15    lcms \
16"
17
18
19inherit gnomebase pkgconfig gsettings gobject-introspection gettext mime-xdg features_check gtk-icon-cache
20
21# FIXME: whilst eog uses libpeas <2, g-i is needed. This can be removed when libpeas2 is used.
22REQUIRED_DISTRO_FEATURES = "opengl gobject-introspection-data"
23
24SRC_URI[archive.sha256sum] = "8650f662d4921d83a7904f6bb9ca245baf735f717b47fac5b37f0d90e5e891a8"
25
26GTKDOC_MESON_OPTION = "gtk_doc"
27
28EXTRA_OEMESON = "-Dxmp=false"
29
30FILES:${PN} += "${datadir}"
31