1SUMMARY = "libmypaint is a library for making brushstrokes"
2LICENSE = "ISC"
3LIC_FILES_CHKSUM = "file://COPYING;md5=9d13203ab4013e5a14dd62105f75d58b"
4
5DEPENDS = " \
6    glib-2.0-native \
7    intltool-native \
8    glib-2.0 \
9    babl \
10    json-c \
11"
12
13inherit autotools gobject-introspection gettext pkgconfig python3native
14
15SRC_URI = "git://github.com/mypaint/libmypaint.git;protocol=https;branch=libmypaint-v1 \
16           file://0001-make-build-compatible-w.-autoconf-2.7.patch \
17          "
18SRCREV = "2768251dacce3939136c839aeca413f4aa4241d0"
19PV = "1.6.1"
20S = "${WORKDIR}/git"
21
22do_configure:append() {
23    # autogen uses python2 so generate headers ourselves
24    cd ${S}
25    python3 generate.py mypaint-brush-settings-gen.h brushsettings-gen.h
26}
27