1SUMMARY = "FAT filesystems explore, extract, repair, and forensic tool"
2DESCRIPTION = "This tool is designed to manipulate FAT filesystems, in order to \
3explore, extract, repair, recover and forensic them. It currently supports \
4FAT12, FAT16 and FAT32."
5HOMEPAGE = "https://github.com/Gregwar/fatcat"
6
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=57fbbfebd0dd1d6ff21b8cecb552a03f"
9
10SRC_URI = "git://github.com/Gregwar/fatcat.git;branch=master;protocol=https \
11           file://0001-Use-unistd.h-not-argp.h-for-all-POSIX-systems.patch \
12           file://0002-Enable-64bit-off_t.patch \
13           file://0001-Replace-std-ptr_fun-for-c-17.patch \
14           "
15
16SRCREV = "99cb99fc86eb1601ac7ae27f5bba23add04d2543"
17
18S = "${WORKDIR}/git"
19
20inherit cmake
21