1SUMMARY = "Set of GPL'ed utilities to ext2/ext3 filesystem."
2DESCRIPTION = "e2tools is a simple set of GPL'ed utilities to read, write, \
3and manipulate files in an ext2/ext3 filesystem. These utilities access a \
4filesystem directly using the ext2fs library. Can also be used on a Linux \
5machine to read/write to disk images or floppies without having to mount \
6them or have root access."
7HOMEPAGE = "https://github.com/e2tools/e2tools"
8SECTION = "base"
9LICENSE = "GPL-2.0-only"
10LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
11
12DEPENDS += "coreutils e2fsprogs"
13
14PV = "0.1.0+git"
15
16SRC_URI = " \
17           git://github.com/e2tools/e2tools;protocol=https;branch=master \
18           file://run-ptest \
19"
20
21SRCREV = "fd092754a6b65c3a769f74f888668c066f09c36d"
22
23S = "${WORKDIR}/git"
24
25inherit autotools pkgconfig ptest
26
27do_configure:prepend() {
28    git -C "${WORKDIR}/git" reset --hard HEAD
29
30    # To install ptest for this package, special configuration needs to be
31    # done before do_configure(). So, do_configure_ptest() which is scheduled
32    # after do_configure() cannot be used.
33
34    # We only do special configuration if we are installing ptest for this
35    # package.
36    if [ "${@d.getVar('PTEST_ENABLED')}" -eq "1" ]; then
37        # Since we guarantee run-time dependency when installing the ptest for
38        # this package, we do not need the check macros under section "checks
39        # for programs" in "configure.ac". Plus, these check macros set the
40        # ouput variables to incorrect values as these checks are performed on
41        # the host environment. Still, we need these variables outputted from
42        # these check macros. So, we insert the following lines to manually
43        # set these output variables to the correct value in "configure.ac".
44
45        # Note that HAVE_DD_COMMAND and HAVE_MKE2FS_COMMAND are only ever used
46        # in tests/Makefile-files which determines whether to include the test
47        # cases. As for output variables CHMOD, DD, and MKE2FS, they only
48        # point to the programs which test cases need to run. Since these
49        # commands are guaranteed to be present due to RDEPENDS and are
50        # guaranteed to be accessible under PATH environment variable on the
51        # target, we only need to specify the name of these programs.
52
53        perl -i -0777 -pe 's/(^dnl\s*=+\s*^dnl\s*Checks for compiler flags\s*^dnl\s*=+)/
54AC_SUBST([CHMOD], 'chmod')
55AC_SUBST([DD], 'dd')
56AC_SUBST([MKE2FS], 'mke2fs')
57AM_CONDITIONAL([HAVE_DD_COMMAND], [true])
58AM_CONDITIONAL([HAVE_MKE2FS_COMMAND], [true])
59\1/ms' "${WORKDIR}/git/configure.ac"
60    fi
61}
62
63do_install_ptest() {
64    rm -rf "${D}${PTEST_PATH}/*"
65    cp -r ../build "${D}${PTEST_PATH}"
66    cp -r "${S}/build-aux" "${D}${PTEST_PATH}/build"
67    cp -r "${S}" "${D}${PTEST_PATH}"
68    rm -rf ${D}${PTEST_PATH}/build/config.log ${D}${PTEST_PATH}/build/autom4te.cache \
69        ${D}${PTEST_PATH}/git/.git ${D}${PTEST_PATH}/git/autom4te.cache
70    sed -i -e 's;${RECIPE_SYSROOT};;g' ${D}${PTEST_PATH}/build/config.status
71}
72
73RDEPENDS:${PN}-ptest += "bash coreutils e2fsprogs e2tools gawk make perl"
74
75BBCLASSEXTEND = "native"
76