1SUMMARY = "Yet Another Flash File System"
2DESCRIPTION = "Tools for managing 'yaffs2' file systems."
3
4SECTION = "base"
5HOMEPAGE = "http://www.yaffs.net"
6
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://utils/mkyaffs2image.c;beginline=11;endline=13;md5=5f5464f9b3e981ca574e65b00e438561 \
9                    file://utils/mkyaffsimage.c;beginline=10;endline=12;md5=5f5464f9b3e981ca574e65b00e438561 \
10                    "
11
12PV = "0.0+git${SRCPV}"
13
14DEPENDS = "mtd-utils"
15
16# Source is the HEAD of master branch at the time of writing this recipe
17SRC_URI = "git://www.aleph1.co.uk/yaffs2;protocol=git;branch=master \
18           file://makefile-add-ldflags.patch \
19           file://0001-define-loff_t-if-not-already-defined.patch \
20           "
21
22SRCREV = "3439fa4e60dd9799766b2c101f799ed9e565b632"
23
24UPSTREAM_CHECK_COMMITS = "1"
25
26S = "${WORKDIR}/git"
27
28CFLAGS_append = " -I.. -DCONFIG_YAFFS_UTIL -DCONFIG_YAFFS_DEFINES_TYPES"
29EXTRA_OEMAKE = "-e MAKEFLAGS="
30
31do_compile() {
32    cd utils && oe_runmake
33}
34
35INSTALL_FILES = "mkyaffsimage \
36                 mkyaffs2image \
37                "
38do_install() {
39    install -d ${D}${sbindir}/
40    for i in ${INSTALL_FILES}; do
41        install -m 0755 utils/$i ${D}${sbindir}/
42    done
43}
44
45BBCLASSEXTEND = "native"
46