1SUMMARY = "FUSE module for mounting an entire SMB/NMB network in a single directory"
2DESCRIPTION = "SMBNetFS is a Linux/FreeBSD filesystem that allow you to use \
3               samba/microsoft network in the same manner as the network \
4               neighborhood in Microsoft Windows. Please donate me to help \
5               in SMBNetFS development."
6
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a"
9HOMEPAGE ="http://sourceforge.net/projects/smbnetfs"
10
11DEPENDS = "fuse samba"
12DEPENDS_append_libc-musl = " libexecinfo"
13
14inherit autotools pkgconfig features_check
15
16# samba depends on libpam
17REQUIRED_DISTRO_FEATURES = "pam"
18
19PV = "0.6.1+git${SRCPV}"
20
21SRCREV = "a117eec8de7ed7249871da73dcc350283ce72069"
22
23SRC_URI = "git://smbnetfs.git.sourceforge.net/gitroot/smbnetfs/smbnetfs;branch=master \
24           file://configure.patch \
25           file://Using-PKG_CHECK_MODULES-to-found-headers-and-libraries.patch"
26
27PACKAGECONFIG ??= ""
28PACKAGECONFIG[libsecret] = "--with-libsecret=yes,--with-libsecret=no,libsecret"
29
30S = "${WORKDIR}/git"
31
32LDFLAGS_append_libc-musl = " -lexecinfo"
33