1SUMMARY = "1-Wire file system"
2DESCRIPTION = "OWFS is an easy way to use the powerful 1-wire system of Dallas/Maxim"
3HOMEPAGE = "http://www.owfs.org/"
4SECTION = "console/network"
5
6LICENSE = "GPL-2.0-only & LGPL-2.0-only"
7LIC_FILES_CHKSUM = "file://COPYING;md5=628b867016631792781a8735a04760e5 \
8                    file://COPYING.LIB;md5=9021b7435efdd9fb22beef8291134099"
9
10DEPENDS = "fuse virtual/libusb0"
11# v3.2p3
12SRCREV = "3744375dfaa350e31c9b360eb1e1a517bbeb5c47"
13SRC_URI = "git://github.com/owfs/owfs;branch=master;protocol=https \
14           file://0001-Add-build-rule-for-README.patch \
15           file://0001-Fix-compilation-with-GCC10.patch \
16           file://owhttpd \
17           file://owserver \
18           "
19
20S = "${WORKDIR}/git"
21
22inherit autotools-brokensep update-rc.d pkgconfig systemd
23
24EXTRA_OECONF = " \
25                 --with-fuseinclude=${STAGING_INCDIR} \
26                 --with-fuselib=${STAGING_LIBDIR} \
27                 --enable-owfs \
28                 --enable-owhttpd \
29                 --enable-w1 \
30                 --disable-swig \
31                 --disable-owtcl \
32                 --disable-owphp \
33                 --disable-owpython \
34                 --disable-owperl \
35"
36
37do_install:prepend() {
38    install -d ${D}${sysconfdir}/default/
39    install -d ${D}${sysconfdir}/init.d/
40    install -m 0755 ${WORKDIR}/owhttpd ${D}${sysconfdir}/init.d/owhttpd
41    install -m 0755 ${WORKDIR}/owserver ${D}${sysconfdir}/init.d/owserver
42}
43
44PACKAGES =+ "owftpd owhttpd owserver owshell libowcapi libow libownet owmon owtap"
45
46DESCRIPTION:owftpd = "Anoymous FTP server for 1-wire access"
47DESCRIPTION:owhttpd = "Tiny webserver for 1-wire control"
48DESCRIPTION:owserver = "Backend server (daemon) for 1-wire control"
49DESCRIPTION:owshell = "owdir owread owwrite owpresent owget - lightweight owserver access"
50DESCRIPTION:libowcapi = "easy C-language 1-wire interface "
51DESCRIPTION:libow = "easy C-language 1-wire interface to the owserver protocol"
52DESCRIPTION:libownet = "easy C-language 1-wire interface to the owserver protocol"
53DESCRIPTION:owmon = "Monitor for owserver settings and statistics"
54DESCRIPTION:owtap = "Packet sniffer for the owserver protocol"
55
56FILES:owftpd = "${bindir}/owftpd ${systemd_system_unitdir}/owftpd.service"
57FILES:owhttpd = "${bindir}/owhttpd ${sysconfdir}/init.d/owhttpd \
58                 ${systemd_system_unitdir}/owhttpd.service"
59FILES:owserver = "${bindir}/owserver ${sysconfdir}/init.d/owserver \
60                  ${systemd_system_unitdir}/owserver.service \
61                  ${systemd_system_unitdir}/owserver.socket"
62FILES:owshell = "${bindir}/owread ${bindir}/owwrite \
63                 ${bindir}/owdir ${bindir}/owpresent \
64                 ${bindir}/owget ${bindir}/owside"
65FILES:owmon = "${bindir}/owmon"
66FILES:owtap = "${bindir}/owtap"
67FILES:libowcapi = "${libdir}/libowcapi-*"
68FILES:libow = "${libdir}/libow-*"
69FILES:libownet = "${libdir}/libownet-*"
70FILES:${PN} += "${systemd_system_unitdir}/owfs.service"
71
72INITSCRIPT_PACKAGES = "owhttpd owserver"
73INITSCRIPT_NAME:owserver = "owserver"
74INITSCRIPT_NAME:owhttpd = "owhttpd"
75INITSCRIPT_PARAMS:owserver = "defaults 20"
76INITSCRIPT_PARAMS:owhttpd = "defaults 21"
77
78SYSTEMD_SERVICE:${PN} = "owfs.service"
79SYSTEMD_SERVICE:${PN}-owftpd = "owftpd.service"
80SYSTEMD_SERVICE:${PN}-owhttpd = "owhttpd.service"
81SYSTEMD_SERVICE:${PN}-owserver = "owserver.service owserver.socket"
82