1SUMMARY = "Image Generation and Programming Scripts for NPCM7XX (Poleg) devices"
2DESCRIPTION = "Image Generation and Programming Scripts for NPCM7XX (Poleg) devices"
3HOMEPAGE = "https://github.com/Nuvoton-Israel/igps"
4LICENSE = "GPL-2.0-only"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
6
7SRC_URI = " \
8    git://github.com/Nuvoton-Israel/igps;branch=master;protocol=https \
9    file://0001-Adjust-paths-for-use-with-Bitbake.patch \
10"
11# tag IGPS_02.01.18
12SRCREV = "e0fc2ba58d561220a957bc06aefe1ac7f6e96126"
13
14S = "${WORKDIR}/git"
15
16DEST = "${D}${datadir}/${BPN}"
17
18do_install() {
19	install -d ${DEST}
20	install ImageGeneration/references/BootBlockAndHeader_${IGPS_MACHINE}.xml ${DEST}
21	install ImageGeneration/references/UbootHeader_${IGPS_MACHINE}.xml ${DEST}
22	install ImageGeneration/inputs/mergedBootBlockAndUboot.xml ${DEST}
23}
24
25inherit native
26