1SUMMARY = "Intel OEM IPMI commands"
2DESCRIPTION = "Intel OEM IPMI commands"
3
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=a6a4edad4aed50f39a66d098d74b265b"
6
7SRC_URI = "git://github.com/openbmc/intel-ipmi-oem;branch=master;protocol=https"
8SRCREV = "84c203d2b74680e9dd60d1c48a2f6ca8f58462bf"
9
10S = "${WORKDIR}/git"
11PV = "0.1+git${SRCPV}"
12
13DEPENDS = "boost phosphor-ipmi-host phosphor-logging systemd phosphor-dbus-interfaces libgpiod libtinyxml2"
14
15inherit cmake obmc-phosphor-ipmiprovider-symlink pkgconfig
16
17EXTRA_OECMAKE="-DENABLE_TEST=0 -DYOCTO=1"
18
19LIBRARY_NAMES = "libzinteloemcmds.so"
20
21HOSTIPMI_PROVIDER_LIBRARY += "${LIBRARY_NAMES}"
22NETIPMI_PROVIDER_LIBRARY += "${LIBRARY_NAMES}"
23
24FILES:${PN}:append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
25FILES:${PN}:append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
26FILES:${PN}:append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
27FILES:${PN}-dev:append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV}"
28
29do_install:append(){
30   install -d ${D}${includedir}/intel-ipmi-oem
31   install -m 0644 -D ${S}/include/*.hpp ${D}${includedir}/intel-ipmi-oem
32}
33