1e1615142SBrad BishopPACKAGECONFIG_append_witherspoon-tacoma = " openpower-pels"
2dd62594aSAdriana KobylakPACKAGECONFIG_append_p10bmc = " openpower-pels"
307dedc26SMatt Spinler
407dedc26SMatt SpinlerFILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
507dedc26SMatt Spinler
607dedc26SMatt SpinlerSRC_URI_append_p10bmc = " file://ibm,rainier-2u_dev_callouts.json"
707dedc26SMatt SpinlerSRC_URI_append_p10bmc = " file://ibm,rainier-4u_dev_callouts.json"
807dedc26SMatt SpinlerFILES_${PN}_append_p10bmc = " ${datadir}/phosphor-logging/pels/ibm,rainier-2u_dev_callouts.json"
907dedc26SMatt SpinlerFILES_${PN}_append_p10bmc = " ${datadir}/phosphor-logging/pels/ibm,rainier-4u_dev_callouts.json"
1007dedc26SMatt Spinler
11*fa28a72fSJayanth Othayoth#Enable phal feature, if available.
12*fa28a72fSJayanth OthayothPACKAGECONFIG_append = " ${@bb.utils.filter('OBMC_MACHINE_FEATURES', 'phal', d)}"
13*fa28a72fSJayanth OthayothPACKAGECONFIG[phal] = "-Dphal=enabled, -Dphal=disabled, pdata libekb pdbg"
14*fa28a72fSJayanth Othayoth
1507dedc26SMatt Spinlerdo_install_append_p10bmc() {
1607dedc26SMatt Spinler    install -d ${D}/${datadir}/phosphor-logging/pels
1707dedc26SMatt Spinler    install -m 0644 ${WORKDIR}/ibm,rainier-2u_dev_callouts.json ${D}/${datadir}/phosphor-logging/pels/ibm,rainier-2u_dev_callouts.json
1807dedc26SMatt Spinler    install -m 0644 ${WORKDIR}/ibm,rainier-4u_dev_callouts.json ${D}/${datadir}/phosphor-logging/pels/ibm,rainier-4u_dev_callouts.json
1985161822SAndrew Geissler    ln -s ./ibm,rainier-4u_dev_callouts.json ${D}/${datadir}/phosphor-logging/pels/ibm,rainier-1s4u_dev_callouts.json
2007dedc26SMatt Spinler}
21