1SUMMARY = "YAML configuration for ACx22 systems"
2PR = "r1"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
5
6inherit allarch
7inherit mrw-xml
8
9SRC_URI:ibm-ac-server = " \
10    file://acx22-ipmi-fru-bmc.yaml \
11    file://acx22-ipmi-fru-not-sent-by-host.yaml \
12    file://acx22-ipmi-hwmon-sensors.yaml \
13    file://acx22-ipmi-inventory-sensors.yaml \
14    file://acx22-ipmi-occ-sensors.yaml \
15    file://acx22-ipmi-sensors-mrw.yaml \
16    "
17DEPENDS = " \
18    mrw-native \
19    mrw-perl-tools-native \
20    openpower-yaml-config \
21    "
22
23S = "${WORKDIR}"
24
25ACx22_IPMI_EXTRA_FRU_READ_YAMLS:ibm-ac-server = " \
26    acx22-ipmi-fru-bmc.yaml \
27    acx22-ipmi-fru-not-sent-by-host.yaml \
28    "
29ACx22_IPMI_EXTRA_SENSOR_YAMLS = " \
30    acx22-ipmi-hwmon-sensors.yaml \
31    acx22-ipmi-occ-sensors.yaml \
32    "
33
34do_install() {
35    perlbin="${STAGING_DIR_NATIVE}${bindir}/perl-native/perl"
36    scriptpath=${STAGING_DIR_NATIVE}${bindir}
37    mrw=${STAGING_DIR_NATIVE}${datadir}/obmc-mrw/${MRW_XML}
38    op_configpath=${STAGING_DIR_HOST}${datadir}/openpower-yaml-config
39
40    # generate extra-properties.yaml from the MRW for ipmi-fru-parser
41    $perlbin $scriptpath/gen_fru_properties.pl -m $mrw \
42        -c $op_configpath/ipmi-fru-properties-mrw.yaml \
43        -o extra-properties.yaml ${EXTRA_MRW_SCRIPT_ARGS}
44
45    # generate fru-read.yaml from the MRW, for ipmid and ipmi-fru-parser
46    $perlbin $scriptpath/gen_ipmi_fru.pl -i $mrw \
47        -m $op_configpath/ipmi-hostboot-fru-mrw.yaml \
48        -o fru-read-partial.yaml ${EXTRA_MRW_SCRIPT_ARGS}
49    cat fru-read-partial.yaml ${ACx22_IPMI_EXTRA_FRU_READ_YAMLS} \
50        > fru-read.yaml
51
52    # generate inventory-sensors.yaml from the MRW, for ipmid
53    $perlbin $scriptpath/gen_ipmi_sel.pl -i $mrw \
54        -m acx22-ipmi-inventory-sensors.yaml -o inventory-sensors.yaml \
55        ${EXTRA_MRW_SCRIPT_ARGS}
56
57    # generate sensors.yaml from the MRW, for ipmid
58    cat acx22-ipmi-sensors-mrw.yaml \
59        $op_configpath/ipmi-hostboot-volatile-sensor-mrw.yaml \
60        $op_configpath/ipmi-occ-active-sensor-mrw.yaml \
61        > sensors-mrw.yaml
62    $perlbin $scriptpath/gen_ipmi_sensor.pl -i $mrw -m sensors-mrw.yaml \
63        -o sensors-partial.yaml ${EXTRA_MRW_SCRIPT_ARGS}
64    cat sensors-partial.yaml ${ACx22_IPMI_EXTRA_SENSOR_YAMLS} \
65        > sensors.yaml
66
67    install -m 0644 -D extra-properties.yaml \
68        ${D}${datadir}/${BPN}/ipmi-extra-properties.yaml
69    install -m 0644 -D fru-read.yaml ${D}${datadir}/${BPN}/ipmi-fru-read.yaml
70    install -m 0644 -D inventory-sensors.yaml \
71        ${D}${datadir}/${BPN}/ipmi-inventory-sensors.yaml
72    install -m 0644 -D sensors.yaml ${D}${datadir}/${BPN}/ipmi-sensors.yaml
73}
74
75FILES:${PN}-dev = " \
76    ${datadir}/${BPN}/ipmi-extra-properties.yaml \
77    ${datadir}/${BPN}/ipmi-fru-read.yaml \
78    ${datadir}/${BPN}/ipmi-inventory-sensors.yaml \
79    ${datadir}/${BPN}/ipmi-sensors.yaml \
80    "
81
82ALLOW_EMPTY:${PN} = "1"
83