1e1615142SBrad BishopSUMMARY = "AVSBus control"
2e1615142SBrad BishopPR = "r1"
3e1615142SBrad BishopLICENSE = "Apache-2.0"
4e1615142SBrad BishopLIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
5e1615142SBrad Bishop
6e1615142SBrad Bishopinherit allarch
7e1615142SBrad Bishopinherit obmc-phosphor-systemd
8e1615142SBrad Bishop
9b96c7504SAdriana KobylakRDEPENDS:${PN} += "i2c-tools"
10e1615142SBrad Bishop
11e1615142SBrad BishopS = "${WORKDIR}"
12e1615142SBrad Bishop
13*319bf072SAndrew GeisslerSRC_URI:append:witherspoon = " file://avsbus-enable.sh"
14b96c7504SAdriana KobylakSRC_URI:append:witherspoon = " file://avsbus-disable.sh"
15e1615142SBrad Bishop
16*319bf072SAndrew Geisslerdo_install:witherspoon() {
17e1615142SBrad Bishop        install -d ${D}${bindir}
18e1615142SBrad Bishop        install -m 0755 ${S}/avsbus-enable.sh ${D}${bindir}/avsbus-enable.sh
19*319bf072SAndrew Geissler        install -m 0755 ${S}/avsbus-disable.sh ${D}${bindir}/avsbus-disable.sh
20e1615142SBrad Bishop}
21e1615142SBrad Bishop
22e1615142SBrad Bishop
23e1615142SBrad BishopTMPL_EN= "avsbus-enable@.service"
24e1615142SBrad BishopTMPL_DIS= "avsbus-disable@.service"
25e1615142SBrad BishopINSTFMT_EN= "avsbus-enable@{0}.service"
26e1615142SBrad BishopINSTFMT_DIS= "avsbus-disable@{0}.service"
27e1615142SBrad BishopTGTFMT = "obmc-chassis-poweron@{0}.target"
28e1615142SBrad BishopFMT_EN = "../${TMPL_EN}:${TGTFMT}.requires/${INSTFMT_EN}"
29e1615142SBrad BishopFMT_DIS = "../${TMPL_DIS}:${TGTFMT}.requires/${INSTFMT_DIS}"
30e1615142SBrad Bishop
31*319bf072SAndrew GeisslerSYSTEMD_SERVICE:${PN}:append:witherspoon = " ${TMPL_EN}"
32b96c7504SAdriana KobylakSYSTEMD_SERVICE:${PN}:append:witherspoon = " ${TMPL_DIS}"
33e83c2209SPatrick WilliamsSYSTEMD_LINK:${PN}:append:witherspoon = " ${@compose_list(d, 'FMT_DIS', 'OBMC_CHASSIS_INSTANCES')}"
34*319bf072SAndrew GeisslerSYSTEMD_LINK:${PN}:append:witherspoon = " ${@compose_list(d, 'FMT_EN', 'OBMC_CHASSIS_INSTANCES')}"
35*319bf072SAndrew Geissler
36