1FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
2FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
3
4SRC_URI:append:p10bmc = " file://ibm.json file://ips.json file://keys/"
5SRC_URI:append:p10bmc = " file://p10bmc.cfg"
6
7OTPTOOL_CONFIGS:p10bmc = "${WORKDIR}/ibm.json ${WORKDIR}/ips.json"
8OTPTOOL_KEY_DIR:p10bmc = "${WORKDIR}/keys/"
9
10# !!! Do not copy p10bmc's use of little-endian key ordering !!!
11#
12# The prefered order for production silicon is big-endian. Little-endian is necessary for p10bmc
13# platforms due to development history involving pre-production AST2600 silicon. More discussion
14# here:
15#
16# https://gerrit.openbmc-project.xyz/c/openbmc/openbmc/+/50716
17SOCSEC_SIGN_EXTRA_OPTS = "--rsa_key_order=little"
18
19do_deploy:prepend:p10bmc() {
20	# otptool needs access to the public and private socsec signing keys in the keys/ directory
21	openssl rsa -in ${SOCSEC_SIGN_KEY} -pubout > ${WORKDIR}/keys/rsa_pub_oem_dss_key.pem
22}
23