1SUMMARY = "Romulus ID Button pressed application"
2PR = "r1"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
5
6inherit obmc-phosphor-systemd
7
8DEPENDS += "virtual/obmc-gpio-monitor"
9RDEPENDS:${PN} += "virtual/obmc-gpio-monitor"
10
11S = "${WORKDIR}"
12SRC_URI += "file://toggle_identify_led.sh"
13
14do_install() {
15        install -d ${D}${bindir}
16        install -m 0755 ${WORKDIR}/toggle_identify_led.sh \
17            ${D}${bindir}/toggle_identify_led.sh
18}
19
20SYSTEMD_ENVIRONMENT_FILE:${PN} +="obmc/gpio/id_button"
21
22ID_BUTTON_SERVICE = "id_button"
23
24TMPL = "phosphor-gpio-monitor@.service"
25INSTFMT = "phosphor-gpio-monitor@{0}.service"
26TGT = "multi-user.target"
27FMT = "../${TMPL}:${TGT}.requires/${INSTFMT}"
28
29SYSTEMD_SERVICE:${PN} += "id-button-pressed.service"
30SYSTEMD_LINK:${PN} += "${@compose_list(d, 'FMT', 'ID_BUTTON_SERVICE')}"
31