1SUMMARY = "Romulus AVSBus control"
2PR = "r1"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
5
6inherit obmc-phosphor-systemd
7
8RDEPENDS:${PN} += "i2c-tools bash"
9
10S = "${WORKDIR}"
11SRC_URI += "file://avsbus-enable.sh \
12            file://avsbus-disable.sh"
13
14do_install() {
15        install -d ${D}${bindir}
16        install -m 0755 ${WORKDIR}/avsbus-disable.sh \
17            ${D}${bindir}/avsbus-disable.sh
18        install -m 0755 ${WORKDIR}/avsbus-enable.sh \
19            ${D}${bindir}/avsbus-enable.sh
20}
21
22TMPL_EN= "avsbus-enable@.service"
23TMPL_DIS= "avsbus-disable@.service"
24INSTFMT_EN= "avsbus-enable@{0}.service"
25INSTFMT_DIS= "avsbus-disable@{0}.service"
26TGTFMT = "obmc-chassis-poweron@{0}.target"
27FMT_EN = "../${TMPL_EN}:${TGTFMT}.requires/${INSTFMT_EN}"
28FMT_DIS = "../${TMPL_DIS}:${TGTFMT}.requires/${INSTFMT_DIS}"
29
30SYSTEMD_SERVICE:${PN} += "${TMPL_EN}"
31SYSTEMD_LINK:${PN} += "${@compose_list(d, 'FMT_EN', 'OBMC_CHASSIS_INSTANCES')}"
32SYSTEMD_SERVICE:${PN} += "${TMPL_DIS}"
33SYSTEMD_LINK:${PN} += "${@compose_list(d, 'FMT_DIS', 'OBMC_CHASSIS_INSTANCES')}"
34