1SUMMARY = "nftables systemd wrapper"
2DESCRIPTION = "nftables systemd wrapper"
3PR = "r1"
4PV = "1.0"
5
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
8
9inherit systemd
10
11SRC_URI += " \
12  file://nft-configure.sh \
13  file://nftables.service \
14  "
15
16SYSTEMD_SERVICE:${PN} += "nftables.service"
17
18RDEPENDS:${PN} += " \
19  bash \
20  nftables \
21  "
22
23do_install() {
24  install -d ${D}${libexecdir}
25  install -m0755 ${WORKDIR}/nft-configure.sh ${D}${libexecdir}/
26
27  install -d ${D}${systemd_system_unitdir}
28  install -m0644 ${WORKDIR}/nftables.service ${D}${systemd_system_unitdir}/
29}
30