1PR = "r1"
2
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
5
6inherit systemd
7
8RDEPENDS:${PN} += "iperf3"
9
10SRC_URI += "file://iperf3.service"
11
12SYSTEMD_SERVICE:${PN} += "iperf3.service"
13
14do_install() {
15  # Install service definitions
16  install -d -m 0755 ${D}${systemd_system_unitdir}
17  install -m 0644 ${WORKDIR}/iperf3.service ${D}${systemd_system_unitdir}
18}
19
20# Allow IPERF3 to run on the gbmcbr node on DEV builds
21do_install:append:dev() {
22  nftables_dir=${D}${sysconfdir}/nftables
23  rules=$nftables_dir/50-gbmc-iperf3-dev.rules
24  install -d -m0755 $nftables_dir
25  echo 'table inet filter {' >"$rules"
26  echo '    chain gbmc_br_pub_input {' >>"$rules"
27  echo '        tcp dport 5201 accept' >>"$rules"
28  echo '    }' >>"$rules"
29  echo '}' >>"$rules"
30}
31