1SUMMARY = "Allows hooking netlink events to perform network actions"
2PR = "r1"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
5
6inherit systemd
7
8SRC_URI += " \
9  file://gbmc-ip-monitor.service \
10  file://gbmc-ip-monitor.sh \
11  file://gbmc-ip-monitor-test.sh \
12  "
13
14S = "${WORKDIR}/sources"
15UNPACKDIR = "${S}"
16
17DEPENDS += "test-sh"
18
19RDEPENDS:${PN} += " \
20  bash \
21  iproute2 \
22  "
23
24SYSTEMD_SERVICE:${PN} += "gbmc-ip-monitor.service"
25
26do_compile() {
27  SYSROOT="$PKG_CONFIG_SYSROOT_DIR" bash gbmc-ip-monitor-test.sh || exit
28}
29
30do_install:append() {
31  install -d -m0755 ${D}${libexecdir}
32  install -m0755 gbmc-ip-monitor.sh ${D}${libexecdir}/
33
34  install -d -m0755 ${D}${systemd_system_unitdir}
35  install -m0644 gbmc-ip-monitor.service ${D}${systemd_system_unitdir}/
36}
37