1SUMMARY = "Google Sys OEM commands"
2DESCRIPTION = "Google Sys OEM commands"
3HOMEPAGE = "https://github.com/openbmc/google-ipmi-sys"
4PR = "r1"
5PV = "0.1+git${SRCPV}"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
8
9inherit autotools pkgconfig
10inherit systemd
11inherit obmc-phosphor-ipmiprovider-symlink
12
13DEPENDS += "autoconf-archive-native"
14DEPENDS += "sdbusplus"
15DEPENDS += "phosphor-logging"
16DEPENDS += "phosphor-ipmi-host"
17DEPENDS += "nlohmann-json"
18
19S = "${WORKDIR}/git"
20SRC_URI = "git://github.com/openbmc/google-ipmi-sys"
21SRCREV = "3b1b427c1fa4bcddcab1fc003410e5fa5d7a8334"
22
23FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
24FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
25FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
26FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
27
28HOSTIPMI_PROVIDER_LIBRARY += "libsyscmds.so"
29
30SYSTEMD_PACKAGES = "${PN}"
31SYSTEMD_SERVICE_${PN} = "gbmc-psu-hardreset.target"
32
33EXTRA_OECONF += "--disable-tests"
34
35CXXFLAGS_append_gbmc = '${@"" if not d.getVar("GBMC_NCSI_IF_NAME") else \
36  " -DNCSI_IPMI_CHANNEL=1 -DNCSI_IF_NAME=" + d.getVar("GBMC_NCSI_IF_NAME")}'
37
38do_install_append() {
39	install -d ${D}${systemd_system_unitdir}
40	install -m 0644 ${S}/gbmc-psu-hardreset.target ${D}${systemd_system_unitdir}
41}
42