1SUMMARY = "Google Sys OEM commands"
2DESCRIPTION = "Google Sys OEM commands"
3HOMEPAGE = "https://github.com/openbmc/google-ipmi-sys"
4PR = "r1"
5PV = "0.1+git${SRCPV}"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
8
9inherit meson pkgconfig systemd
10
11DEPENDS += " \
12  nlohmann-json \
13  phosphor-dbus-interfaces \
14  phosphor-logging \
15  phosphor-ipmi-host \
16  sdbusplus \
17  systemd \
18  "
19
20S = "${WORKDIR}/git"
21SRC_URI = "git://github.com/openbmc/google-ipmi-sys;branch=master;protocol=https"
22SRCREV = "4baf41c8d22b975d5bfb65fccb5e1cb1ae2efd3d"
23
24FILES:${PN} += "${libdir}/ipmid-providers"
25
26SYSTEMD_PACKAGES = "${PN}"
27SYSTEMD_SERVICE:${PN} += " \
28  gbmc-host-poweroff.target \
29  gbmc-psu-hardreset.target \
30  gbmc-psu-hardreset-pre.target \
31  gbmc-psu-hardreset-time.service \
32  "
33
34EXTRA_OEMESON += "-Dtests=disabled"
35
36CXXFLAGS:append:gbmc = '${@"" if not d.getVar("GBMC_NCSI_IF_NAME") else \
37  " -DNCSI_IPMI_CHANNEL=1 -DNCSI_IF_NAME=" + d.getVar("GBMC_NCSI_IF_NAME")}'
38