1PR = "r1"
2PV = "0.1+git${SRCPV}"
3LICENSE = "GPL-2.0-or-later"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=4325afd396febcb659c36b49533135d4"
5
6SRC_URI = "git://github.com/mstpd/mstpd;branch=master;protocol=https"
7SRCREV = "973c403c79f3d419d9e93a242766ddf0099d1299"
8S = "${WORKDIR}/git"
9
10SRC_URI += "file://bridge-stp"
11SRC_URI += "file://mstpd.service"
12
13inherit autotools pkgconfig systemd
14
15PACKAGES =+ "${PN}-mstpd"
16FILES:${PN}-mstpd = "${sbindir}/mstpd ${sbindir}/mstpctl /sbin/bridge-stp"
17
18SYSTEMD_PACKAGES = "${PN}-mstpd"
19SYSTEMD_SERVICE:${PN}-mstpd = "mstpd.service"
20
21do_install:append() {
22  rm -r ${D}${libexecdir}
23
24  install -d -m 0755 ${D}/sbin
25  install -m 0755 ${WORKDIR}/bridge-stp ${D}/sbin
26
27  install -d -m 0755 ${D}${systemd_system_unitdir}
28  install -m 0644 ${WORKDIR}/mstpd.service ${D}${systemd_system_unitdir}/
29}
30