1SUMMARY = "Phosphor OpenBMC Kudo Firmware Upgrade Command"
2DESCRIPTION = "Phosphor OpenBMC Kudo Firmware Upgrade Comman Daemon"
3
4PR = "r1"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
7
8inherit systemd
9inherit obmc-phosphor-systemd
10
11DEPENDS += "systemd"
12DEPENDS += "phosphor-ipmi-flash"
13RDEPENDS:${PN} += "libsystemd"
14RDEPENDS:${PN} += "bash"
15
16
17SRC_URI = " \
18    file://kudo-fw.sh \
19    file://kudo-fw-ver.service \
20    file://kudo-fw-ver.sh \
21    file://kudo-lib.sh \
22    "
23
24SYSTEMD_PACKAGES = "${PN}"
25SYSTEMD_SERVICE:${PN} = " \
26    kudo-fw-ver.service \
27    "
28
29do_install () {
30    install -d ${D}${sbindir}
31    install -d ${D}${libexecdir}/${PN}
32    install -m 0755 ${WORKDIR}/kudo-fw.sh ${D}${sbindir}/kudo-fw.sh
33    install -m 0755 ${WORKDIR}/kudo-fw-ver.sh ${D}${libexecdir}/${PN}/kudo-fw-ver.sh
34    install -m 0755 ${WORKDIR}/kudo-lib.sh ${D}${libexecdir}/${PN}/kudo-lib.sh
35    install -d ${D}${systemd_system_unitdir}
36    install -m 0644 ${WORKDIR}/kudo-fw-ver.service ${D}${systemd_system_unitdir}
37}
38