1SUMMARY = "Facebook OEM IPMI commands"
2DESCRIPTION = "Facebook OEM IPMI commands"
3
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=9e69ba356fa59848ffd865152a3ccc13"
6
7SRC_URI = "git://github.com/openbmc/fb-ipmi-oem;branch=master;protocol=https"
8SRCREV = "2405ae98b39a97e9d7753d8dc5c673a4a8885b85"
9
10S = "${WORKDIR}/git"
11PV = "0.1+git${SRCPV}"
12
13DEPENDS = "boost phosphor-ipmi-host phosphor-logging systemd "
14
15inherit meson pkgconfig obmc-phosphor-ipmiprovider-symlink
16
17PACKAGECONFIG ??= ""
18PACKAGECONFIG:fb-compute-multihost ??= "bic"
19
20PACKAGECONFIG[bic] = "-Dbic=enabled,-Dbic=disabled"
21
22EXTRA_OEMESON="\
23    -Dtests=disabled \
24    -Dmachine='${MACHINE}' \
25    -Dhost-instances='${OBMC_HOST_INSTANCES}' \
26    "
27
28LIBRARY_NAMES = "libzfboemcmds.so"
29
30HOSTIPMI_PROVIDER_LIBRARY += "${LIBRARY_NAMES}"
31NETIPMI_PROVIDER_LIBRARY += "${LIBRARY_NAMES}"
32
33FILES:${PN}:append = " ${datadir}/lcd-debug/*.json"
34
35FILES:${PN}:append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
36FILES:${PN}:append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
37FILES:${PN}:append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
38FILES:${PN}-dev:append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV}"
39
40do_install:append(){
41   install -d ${D}${includedir}/fb-ipmi-oem
42   install -m 0644 -D ${S}/include/*.hpp ${D}${includedir}/fb-ipmi-oem
43}
44