1SUMMARY = "Enable USB ethernet"
2PR = "r1"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
5
6DEPENDS += "systemd"
7RDEPENDS:${PN} += "libsystemd"
8
9inherit allarch systemd
10
11SRC_URI += "file://usb_network.service \
12            file://00-bmc-usb0.network"
13
14do_install() {
15    install -d ${D}${systemd_unitdir}/system/
16    install -m 0644 ${WORKDIR}/usb_network.service ${D}${systemd_unitdir}/system
17
18    install -d ${D}${sysconfdir_native}/systemd/network/
19    install -m 0644 ${WORKDIR}/00-bmc-usb0.network ${D}${sysconfdir_native}/systemd/network
20}
21
22NATIVE_SYSTEMD_SUPPORT = "1"
23SYSTEMD_PACKAGES = "${PN}"
24SYSTEMD_SERVICE:${PN} = "usb_network.service"
25