1SUMMARY = "Enforce static MAC addresses"
2DESCRIPTION = "Set a priority on MAC addresses to run with: \
3               factory-specified > u-boot-specified > random"
4
5FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
6
7PR = "r1"
8LICENSE = "Apache-2.0"
9LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
10
11inherit allarch
12SRC_URI = "\
13    file://mac-check \
14    file://${PN}.service \
15    "
16
17inherit obmc-phosphor-systemd
18
19SYSTEMD_SERVICE:${PN} += "${PN}.service"
20
21do_install() {
22    install -d ${D}${bindir}
23    install -m 0755 ${WORKDIR}/mac-check ${D}${bindir}
24}
25