1SUMMARY = "EDK2 Test Parser"
2DESCRIPTION = "EDK2 Test Parser for parsing the results of UEFI SCT tests"
3HOMEPAGE = "https://gitlab.arm.com/systemready/edk2-test-parser"
4
5inherit native
6
7LICENSE = "BSD-2-Clause"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=c0550be4b3b9c0223efd0eaa70dc9085"
9
10RDEPENDS:${PN} = "python3-packaging-native python3-pyyaml-native \
11                  python3-jsonschema-native"
12
13PV = "v2023.04"
14S = "${WORKDIR}/git"
15SRC_URI = "git://git.gitlab.arm.com/systemready/edk2-test-parser.git;protocol=https;nobranch=1"
16
17# The SRCREV is at the v2023.04 tag
18SRCREV  = "e8cdb692592d2a152cb87cf4d9fbd7ba2ae8b405"
19
20do_install() {
21    install -d ${D}/${libdir}/edk2_test_parser
22    cp -r ${S}/* ${D}/${libdir}/edk2_test_parser
23}
24
25do_configure[noexec] = "1"
26do_compile[noexec] = "1"
27