1SUMMARY = "Ampere OEM IPMI commands"
2DESCRIPTION = "Ampere OEM IPMI commands"
3
4LICENSE = "Apache-2.0"
5S = "${WORKDIR}"
6
7LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
8
9DEPENDS = "boost phosphor-ipmi-host phosphor-logging systemd"
10
11inherit meson pkgconfig obmc-phosphor-ipmiprovider-symlink
12
13LIBRARY_NAMES = "libzampoemcmds.so"
14
15S = "${WORKDIR}/git"
16SRC_URI = "git://github.com/openbmc/ampere-ipmi-oem.git;branch=master;protocol=https"
17SRCREV = "ee2e1df6ca5fd87b401d4eb15b80224f3025a612"
18
19HOSTIPMI_PROVIDER_LIBRARY += "${LIBRARY_NAMES}"
20NETIPMI_PROVIDER_LIBRARY += "${LIBRARY_NAMES}"
21
22FILES:${PN}:append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
23FILES:${PN}:append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
24FILES:${PN}:append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
25FILES:${PN}-dev:append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV}"
26
27do_install:append(){
28   install -d ${D}${includedir}/ampere-ipmi-oem
29   install -m 0644 -D ${S}/include/*.hpp ${D}${includedir}/ampere-ipmi-oem
30}
31