1SUMMARY = "Ampere Computing LLC Host Control Implementation"
2DESCRIPTION = "A host control implementation suitable for Ampere Computing LLC's systems"
3PR = "r1"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
6
7inherit systemd
8inherit obmc-phosphor-systemd
9
10RDEPENDS:${PN} = "bash"
11S = "${WORKDIR}"
12
13SRC_URI = " \
14           file://ampere-host-force-reset@.service \
15           file://ampere-host-on-host-check@.service \
16           file://ampere_host_check.sh \
17          "
18
19SYSTEMD_PACKAGES = "${PN}"
20SYSTEMD_SERVICE:${PN} = " \
21                         ampere-host-force-reset@.service \
22                        "
23
24# append force reboot
25HOST_WARM_REBOOT_FORCE_TGT = "ampere-host-force-reset@.service"
26HOST_WARM_REBOOT_FORCE_INSTMPL = "ampere-host-force-reset@{0}.service"
27HOST_WARM_REBOOT_FORCE_TGTFMT = "obmc-host-force-warm-reboot@{0}.target"
28HOST_WARM_REBOOT_FORCE_TARGET_FMT = "../${HOST_WARM_REBOOT_FORCE_TGT}:${HOST_WARM_REBOOT_FORCE_TGTFMT}.requires/${HOST_WARM_REBOOT_FORCE_INSTMPL}"
29SYSTEMD_LINK:${PN} += "${@compose_list_zip(d, 'HOST_WARM_REBOOT_FORCE_TARGET_FMT', 'OBMC_HOST_INSTANCES')}"
30SYSTEMD_SERVICE:${PN} += "${HOST_WARM_REBOOT_FORCE_TGT}"
31
32HOST_ON_RESET_HOSTTMPL = "ampere-host-on-host-check@.service"
33HOST_ON_RESET_HOSTINSTMPL = "ampere-host-on-host-check@{0}.service"
34HOST_ON_RESET_HOSTTGTFMT = "obmc-host-startmin@{0}.target"
35HOST_ON_RESET_HOSTFMT = "../${HOST_ON_RESET_HOSTTMPL}:${HOST_ON_RESET_HOSTTGTFMT}.requires/${HOST_ON_RESET_HOSTINSTMPL}"
36SYSTEMD_LINK:${PN} += "${@compose_list_zip(d, 'HOST_ON_RESET_HOSTFMT', 'OBMC_HOST_INSTANCES')}"
37SYSTEMD_SERVICE:${PN} += "${HOST_ON_RESET_HOSTTMPL}"
38
39do_install() {
40    install -d ${D}/usr/sbin
41    install -m 0755 ${WORKDIR}/ampere_host_check.sh ${D}/${sbindir}/
42}
43