xref: /openbmc/openbmc/meta-openembedded/meta-python/recipes-devtools/python/python3-pyruvate_1.2.1.bb (revision edff49234e31f23dc79f823473c9e286a21596c1)
18e7b46e2SPatrick WilliamsSUMMARY = "WSGI server implemented in Rust."
28e7b46e2SPatrick WilliamsDESCRIPTION = "Pyruvate is a reasonably fast, multithreaded, non-blocking \
38e7b46e2SPatrick WilliamsWSGI server implemented in Rust."
48e7b46e2SPatrick WilliamsHOMEPAGE = "https://gitlab.com/tschorr/pyruvate"
58e7b46e2SPatrick WilliamsBUGTRACKER = "https://gitlab.com/tschorr/pyruvate/-/issues"
68e7b46e2SPatrick Williams
78e7b46e2SPatrick WilliamsLICENSE = "GPL-2.0-only"
88e7b46e2SPatrick WilliamsLIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
98e7b46e2SPatrick Williams
108e7b46e2SPatrick WilliamsSRC_URI += "\
118e7b46e2SPatrick Williams    git://gitlab.com/tschorr/pyruvate.git;protocol=https;branch=main \
12*edff4923SAndrew Geissler    file://0001-linux.rs-Define-consts-for-rv32-architecture.patch;patchdir=${UNPACKDIR}/cargo_home/bitbake/nix-0.23.2/ \
13*edff4923SAndrew Geissler    file://0001-musl-Define-SOCK_NONBLOCK-with-O_NONBLOCK.patch;patchdir=${UNPACKDIR}/cargo_home/bitbake/libc-0.2.138/ \
14*edff4923SAndrew Geissler    file://0001-musl-riscv32-Define-F_SETLK-F_SETLKW-and-fix-F_GETLK.patch;patchdir=${UNPACKDIR}/cargo_home/bitbake/libc-0.2.138/ \
15*edff4923SAndrew Geissler    file://0001-musl-Move-F_OFD_GETLK-F_OFD_SETLK-and-F_OFD_SETLKW-t.patch;patchdir=${UNPACKDIR}/cargo_home/bitbake/libc-0.2.138/ \
16*edff4923SAndrew Geissler    file://0001-musl-Define-O_LARGEFILE-for-riscv32.patch;patchdir=${UNPACKDIR}/cargo_home/bitbake/libc-0.2.138/ \
17*edff4923SAndrew Geissler    file://0001-musl-Define-SOCK_SEQPACKET-in-common-place.patch;patchdir=${UNPACKDIR}/cargo_home/bitbake/libc-0.2.138/ \
188e7b46e2SPatrick Williams"
198e7b46e2SPatrick WilliamsSRCREV = "57db64c9f65ced05c71b8d786c1cedfaa2991597"
208e7b46e2SPatrick Williams
21*edff4923SAndrew GeisslerSRC_URI:append:mips = " file://0001-check-for-mips-targets-for-stat.st_dev-definitions.patch;patchdir=${UNPACKDIR}/cargo_home/bitbake/libsystemd-0.5.0/"
228e7b46e2SPatrick Williams
238e7b46e2SPatrick WilliamsS = "${WORKDIR}/git"
248e7b46e2SPatrick Williams
258e7b46e2SPatrick Williamsinherit python_setuptools3_rust cargo-update-recipe-crates
268e7b46e2SPatrick Williams
278e7b46e2SPatrick Williams# crossbeam-* -> std::sync::atomic AtomicI64, AtomicU64
288e7b46e2SPatrick Williams# not supported on mips/powerpc with 32-bit pointers
298e7b46e2SPatrick Williams# https://doc.rust-lang.org/std/sync/atomic/#portability
308e7b46e2SPatrick WilliamsRUSTFLAGS:append:mips = " --cfg crossbeam_no_atomic_64"
318e7b46e2SPatrick WilliamsRUSTFLAGS:append:mipsel = " --cfg crossbeam_no_atomic_64"
328e7b46e2SPatrick WilliamsRUSTFLAGS:append:powerpc = " --cfg crossbeam_no_atomic_64"
338e7b46e2SPatrick WilliamsRUSTFLAGS:append:riscv32 = " --cfg crossbeam_no_atomic_64"
348e7b46e2SPatrick Williams
358e7b46e2SPatrick Williamsrequire ${BPN}-crates.inc
368e7b46e2SPatrick Williams
378e7b46e2SPatrick Williams# The following configs & dependencies are from setuptools extras_require.
388e7b46e2SPatrick Williams# These dependencies are optional, hence can be controlled via PACKAGECONFIG.
398e7b46e2SPatrick Williams# The upstream names may not correspond exactly to bitbake package names.
408e7b46e2SPatrick Williams#
418e7b46e2SPatrick Williams# Uncomment this line to enable all the optional features.
428e7b46e2SPatrick Williams#PACKAGECONFIG ?= "test"
438e7b46e2SPatrick WilliamsPACKAGECONFIG[test] = ",,,python3-pytest python3-requests"
448e7b46e2SPatrick Williams
458e7b46e2SPatrick Williams# WARNING: the following rdepends are determined through basic analysis of the
468e7b46e2SPatrick Williams# python sources, and might not be 100% accurate.
478e7b46e2SPatrick WilliamsRDEPENDS:${PN} += "python3-core"
48