xref: /openbmc/openbmc/meta-openembedded/meta-oe/recipes-multimedia/libcdio/libcdio_2.1.0.bb (revision 8460358c3d24c71d9d38fd126c745854a6301564)
1c342db35SBrad BishopSUMMARY = "The GNU Compact Disc Input and Control library (libcdio) contains a library for CD-ROM and CD image access."
2c342db35SBrad BishopHOMEPAGE = "http://www.gnu.org/software/libcdio/"
3c342db35SBrad BishopSECTION = "libs"
49aee5003SAndrew GeisslerLICENSE = "GPL-3.0-or-later"
5c342db35SBrad BishopLIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
6c342db35SBrad Bishop
7595f6308SAndrew GeisslerSRC_URI = "${GNU_MIRROR}/${BPN}/${BP}.tar.bz2 \
8595f6308SAndrew Geissler           file://0001-Fix-a-few-Werror-format-security-errors-with-mvprint.patch \
9*3eeda90dSAndrew Geissler           file://Drop-LIBCDIO_SOURCE_PATH-by-dropping-STRIP_FROM_PATH.patch \
10595f6308SAndrew Geissler           "
11c342db35SBrad Bishop
12c342db35SBrad BishopSRC_URI[sha256sum] = "8550e9589dbd594bfac93b81ecf129b1dc9d0d51e90f9696f1b2f9b2af32712b"
13c342db35SBrad Bishop
14c342db35SBrad Bishopinherit autotools pkgconfig
15c342db35SBrad Bishop
16c342db35SBrad BishopPACKAGECONFIG ??= "cdda-player"
17c342db35SBrad BishopPACKAGECONFIG[cdda-player] = "--with-cdda-player,--without-cdda-player,ncurses"
18c342db35SBrad BishopPACKAGECONFIG[cddb] = "--enable-cddb,--disable-cddb,libcddb"
19c342db35SBrad BishopPACKAGECONFIG[vcd-info] = "--enable-vcd-info,--disable-vcd-info,vcdimager"
20c342db35SBrad Bishop
2187f5cff0SAndrew Geissler# add -D_LARGEFILE64_SOURCE for 32bit targets
2287f5cff0SAndrew GeisslerCFLAGS += "${@['-D_LARGEFILE64_SOURCE',''][d.getVar('SITEINFO_BITS') != '32']}"
2387f5cff0SAndrew Geissler
24c342db35SBrad BishopPACKAGES += "${PN}-utils"
25c342db35SBrad Bishop
26213cb269SPatrick WilliamsFILES:${PN} = "${libdir}/${BPN}${SOLIB}"
27213cb269SPatrick WilliamsFILES:${PN}-utils = "${bindir}/*"
28c342db35SBrad Bishop
29c342db35SBrad Bishoppython libcdio_split_packages() {
30c342db35SBrad Bishop    libdir = d.expand('${libdir}')
317e0e3c0cSAndrew Geissler    do_split_packages(d, libdir, r'^lib(.*)\.so\..*', 'lib%s', 'libcdio %s library', extra_depends='', allow_links=True)
32c342db35SBrad Bishop}
33c342db35SBrad Bishop
34c342db35SBrad BishopPACKAGESPLITFUNCS =+ "libcdio_split_packages"
35