xref: /openbmc/openbmc/poky/meta/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bb (revision c124f4f2e04dca16a428a76c89677328bc7bf908)
1SUMMARY = "X.Org X server configuration file"
2HOMEPAGE = "http://www.x.org"
3SECTION = "x11/base"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
6
7SRC_URI = "file://xorg.conf"
8
9S = "${WORKDIR}/sources"
10UNPACKDIR = "${S}"
11
12CONFFILES:${PN} = "${sysconfdir}/X11/xorg.conf"
13
14PACKAGE_ARCH = "${MACHINE_ARCH}"
15ALLOW_EMPTY:${PN} = "1"
16
17do_install () {
18	if test -s ${S}/xorg.conf; then
19		install -d ${D}/${sysconfdir}/X11
20		install -m 0644 ${S}/xorg.conf ${D}/${sysconfdir}/X11/
21	fi
22}
23