1#
2# Copyright OpenEmbedded Contributors
3#
4# SPDX-License-Identifier: MIT
5#
6
7# Check types of bitbake configuration variables
8#
9# See oe.types for details.
10
11python check_types() {
12    import oe.types
13    for key in e.data.keys():
14        if e.data.getVarFlag(key, "type"):
15            oe.data.typed_value(key, e.data)
16}
17addhandler check_types
18check_types[eventmask] = "bb.event.ConfigParsed"
19